What latest postgis to use with hibernate-spatial-postgis for postgresql 9.2

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

What latest postgis to use with hibernate-spatial-postgis for postgresql 9.2

Farrukh Najmi
Hi Karel and colleagues,

I am in the process of upgrading my software from:

PostgreSQL: 9.0
PostGIS: 1.5.2
hibernate-core: 3.6.4.Final
hibernate-spatial: 1.1.1
geotools: 2.7-M5

To: PostgreSQL: 9.2

I am trying to decide what version of PostGIS to upgrade to.

I would be grateful for any advice on this.

Also, does it make sense to consider upgrading to hibernate 4 and
hibernate-spatial 4.00-M1 for a production release?
How difficult is the migration impact on existing code and databases?

--
Regards,
Farrukh Najmi

Web: http://www.wellfleetsoftware.com


_______________________________________________
hibernatespatial-users mailing list
[hidden email]
http://www.hibernatespatial.org/cgi-bin/mailman/listinfo/hibernatespatial-users
Reply | Threaded
Open this post in threaded view
|

Re: What latest postgis to use with hibernate-spatial-postgis for postgresql 9.2

Karel Maesen
Administrator
Hi,


On 25 Feb 2013, at 16:30, Farrukh Najmi wrote:
> I am trying to decide what version of PostGIS to upgrade to.
>
> I would be grateful for any advice on this.

I haven't yet tested on Postgis 2.x. Maybe you could check and see if it works. If it doens't, you should use the latest 1.x Postgis release.

>
> Also, does it make sense to consider upgrading to hibernate 4 and hibernate-spatial 4.00-M1 for a production release?

I have received very little bug reports for 4.0-M1, so I think it is stable enough for production.

> How difficult is the migration impact on existing code and databases?

The impact is quite limited. There some renamings (org.hibernatespatial to org.hibernate.spatial) and the GeomtryUserType is now a GeometryType. If you read through the tutorial for 4.0 you'll quickly see the differences. In queries, the geometry types are now correctly inferred by Hibernate which results in cleaner code.

Regards,

Karel

_______________________________________________
hibernatespatial-users mailing list
[hidden email]
http://www.hibernatespatial.org/cgi-bin/mailman/listinfo/hibernatespatial-users
Reply | Threaded
Open this post in threaded view
|

Re: What latest postgis to use with hibernate-spatial-postgis for postgresql 9.2

Farrukh Najmi
On 02/26/2013 09:14 AM, Karel Maesen wrote:
> Hi,
>
>
> On 25 Feb 2013, at 16:30, Farrukh Najmi wrote:
>> I am trying to decide what version of PostGIS to upgrade to.
>>
>> I would be grateful for any advice on this.
> I haven't yet tested on Postgis 2.x. Maybe you could check and see if it works. If it doens't, you should use the latest 1.x Postgis release.

I will do so with postgis 2_92 and let you know on list my findings.

>
>> Also, does it make sense to consider upgrading to hibernate 4 and hibernate-spatial 4.00-M1 for a production release?
> I have received very little bug reports for 4.0-M1, so I think it is stable enough for production.

That sounds promising. I am thinking of postponing Hibernate 4 for next
release to gain some time.

>
>> How difficult is the migration impact on existing code and databases?
> The impact is quite limited. There some renamings (org.hibernatespatial to org.hibernate.spatial) and the GeomtryUserType is now a GeometryType. If you read through the tutorial for 4.0 you'll quickly see the differences. In queries, the geometry types are now correctly inferred by Hibernate which results in cleaner code.
>

--
Regards,
Farrukh Najmi

Web: http://www.wellfleetsoftware.com

_______________________________________________
hibernatespatial-users mailing list
[hidden email]
http://www.hibernatespatial.org/cgi-bin/mailman/listinfo/hibernatespatial-users
Reply | Threaded
Open this post in threaded view
|

Re: What latest postgis to use with hibernate-spatial-postgis for postgresql 9.2

Farrukh Najmi
On 02/26/2013 10:43 AM, Farrukh Najmi wrote:

> On 02/26/2013 09:14 AM, Karel Maesen wrote:
>> Hi,
>>
>>
>> On 25 Feb 2013, at 16:30, Farrukh Najmi wrote:
>>> I am trying to decide what version of PostGIS to upgrade to.
>>>
>>> I would be grateful for any advice on this.
>> I haven't yet tested on Postgis 2.x. Maybe you could check and see if
>> it works. If it doens't, you should use the latest 1.x Postgis release.
>
> I will do so with postgis 2_92 and let you know on list my findings.

Hi Karel,

I have found that hibernate-spatial 1.1.1 seems to be working fine with
postgis 2_92. I did not have to do anything special. I will do more
testing and will post an update if needed tomorrow.

--
Regards,
Farrukh Najmi

Web: http://www.wellfleetsoftware.com

_______________________________________________
hibernatespatial-users mailing list
[hidden email]
http://www.hibernatespatial.org/cgi-bin/mailman/listinfo/hibernatespatial-users